Linux mini-HOWTO


Обычные проблемы и то, чем вы можете заинтересоваться - часть 4


прочитать файл Documentation/Changes и выяснить, какие пакеты требуют обновления в вашей системе

  • использовать наиболее новый пакет modutils, доступный по адресу AlphaBits на Red Hat или на зеркале TSX-11

  • Если вы хотите использовать модули с ядром версии 2.1, я бы порекомендовал использовать ядро, как минимум, версии 2.1.29.

    Q: Что насчет работы с сетью 'дозвон-по-требованию' (dial-on-demand)?

    A: kerneld ранее поддерживал возможность установления dial-up соединения по требованию системы; попытки посылать пакеты в сеть без соединения должны были заставлять kerneld запускать скрипт /sbin/request_route для установления PPP или SLIP соединения.

    Но это была плохая идея. Alan Cox, один из знаменитых специалистов по сетям в Linux, написал в списке рассылки по ядру Linux, что

    Утилита request-route устарела, не работает и не нужна [...] Она также убрана из структур 2.1.x.

    Вместо использования скрипта request-route вместе с kerneld, я настоятельно советую вам установить пакет diald (Eric Schenk), доступный по адресу http://www.dna.lth.se/~erics/diald.html.


    Примечания

    [1]

    (На самом деле, это не совсем так. Поздние версии 1.3.x и все 2.x версии ядер поддерживают режим загрузочного ram-диска, загружаемого LILO или LOADLIN-ом, и также существует возможность загрузить модули с этого "диска" практически в любой момент в процессе загрузки. Как это сделать, описано в файле linux/Documentation/initrd.txt, поставляемом с исходными текстами ядра.)




    - Начало -  - Назад -  - Вперед -



    Книжный магазин